Degraded email sending performance.
Incident Report for Cerkl
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 20:06 EST
Identified
Our sending partner, SendGrid, is experiencing an issue that is causing degraded performance for email sends that they are currently investigating and working to solve. Due to this issue, email sends from Cerkl, both newsletters and blasts, are taking longer than usual to send and you may experience delays. As soon as SendGrid can resolve the issue, Cerkl services will be restored to normal sending performance.
Posted Feb 16, 2021 - 14:59 EST
This incident affected: Newsletters and Blasts.